#135: Have util::vertex and util::edge be distinct types
------------------------+---------------------------------------------------
Reporter: garrigues | Owner: levill_r
Type: defect | Status: assigned
Priority: major | Milestone: Olena 1.0
Component: Milena | Version: 1.0
Resolution: | Keywords:
------------------------+---------------------------------------------------
Changes (by levill_r):
* priority: critical => major
* summary: Rename (graph-related) util::node as util::vertex => Have
util::vertex and util::edge be distinct types
Old description:
* ~~We have two `mln::util::node` types : one for the
graph
implementation and also one for the tree. See
source:/trunk/milena/mln/util/tree.hh and
source:/trunk/milena/mln/util/internal/graph_base.hh. Remove this name
clash.~~ (Fixed; Matthieu Garrigues renamed the tree-related
`mln::util::node` in r1749.)
* Anyway, the graph-related `mln::util::node` should be renamed as
`mln::util::vertex`.
* Even better: `mln::util::vertex` and `mln::util::edge` should be given
two distinct, incompatible types, like Vaucanson's graph item handlers
(ask Roland for more details).
New description:
* ~~We have two `mln::util::node` types : one for the graph implementation
and also one for the tree. See source:/trunk/milena/mln/util/tree.hh and
source:/trunk/milena/mln/util/internal/graph_base.hh. Remove this name
clash.~~ (Fixed; Matthieu Garrigues renamed the tree-related
`mln::util::node` in r1749.)
* ~~Anyway, the graph-related `mln::util::node` should be renamed as
`mln::util::vertex`~~ (done in r1993).
* Even better: `mln::util::vertex` and `mln::util::edge` should be given
two distinct, incompatible types, like Vaucanson's graph item handlers
(ask Roland for more details).
Comment:
s/`util::node`/`util::vertex`/ (r1993).
--
Ticket URL: <https://trac.lrde.org/olena/ticket/135#comment:3>
Olena <http://olena.lrde.epita.fr>
Olena, a generic and efficient C++ image processing library.